Author Topic: Special + Windows 7  (Read 19943 times)

Stops1143

  • Newbie
  • *
  • Posts: 2
    • View Profile
Special + Windows 7
« on: July 23, 2010, 02:58:07 PM »
Hallo,

ich habe eine relativ frische Installation von Windows 7 und MiKTeX 2.8 auf meinem Rechner, zusammen mit WinFig 4.61 (zip-Version)

Schon "Out of the Box" wird mir Special-Text nicht angezeigt. In dem Ordner "C:\Users\Abcde_adm\AppData\Local\Temp" wird zunächst auch die texclip.tex erzeugt. In der texclip.log steht dann, er hätte das compilieren abgebrochen, weil er auf die texclip.aux nicht schreiben konnte. (Hab die log-Datei mal angehangen).
Kompiliere ich die texclip.tex im TexnicCenter geht alles reibungslos und das die testclip.dvi wird erzeugt. Gleiches gilt, wenn ich in der CMD mit:

latex -quiet -job-name texclip texclip.tex

compiliere. (auch hier hab ich das Logfile mal angehangen)

Ich verstehe nun nicht, warum es in Winfig nicht klappt. Hab auch schon versuch anstelle von OUTFILE und INFILE einen anderen Ordner anzugeben. Das hat nämlich nicht geklappt. Hatte nämlich vermutet, dass der Username "Abcde_adm" (Unterstrich) stören könnte. Kann das sein?

Für Lösungvorschläge wäre ich sehr dankbar.

Andreas

  • Administrator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: Special + Windows 7
« Reply #1 on: July 23, 2010, 04:08:38 PM »
Das ist vermutlich ein Rechteproblem. Aus dem Grund habe ich die Erzeugung der TeX-Dateien schon nach "C:\Users\Abcde_adm\AppData\Local\Temp" umgeleitet, weil dort der User Schreibrechte haben sollte. Vorher hatte ich das Applikationsverzeichnis genommen und da gab es unter Win7 genau dieses Problem. Mit dem Temp-Directory hatte es dann funktioniert. Ich würde also mal forschen, warum WinFIG dort nun doch nicht nicht schreiben darf.

Ist denn Abcde_adm ein ganz normaler User?
This forum belongs to www.schmidt-web-berlin.de/winfig

Stops1143

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Special + Windows 7
« Reply #2 on: July 26, 2010, 08:19:26 AM »
Abcde_adm hat eigentlich Administratorrechte. Im Zuge dieses Problems ist mir aber aufgefallen, dass ich auf andere Ordner in meinem Benutzerverzeichnis im Explorer nicht zugreifen kann. Auf diesen aber schon...

Und wenn man den Ordner auf "C:\Temp2 oder so setzt? Wie gesagt, das habe ich auch schon versucht, aber leider nicht hinbekommen.

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #3 on: August 02, 2010, 05:47:48 PM »
Hi,

I guess I am having the same problem as Stops1143: essentially, I cannot render special texts using LaTeX on Windows 7. From what little I could gather from the posts in German, the problem is with administrator rights. In my machine, it seems that WinFIG can save to the Temp folder, but latex cannot. Do you know any solution to this?

Thanks.

Andreas

  • Administrator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: Special + Windows 7
« Reply #4 on: August 03, 2010, 03:26:31 PM »
You could grant full permission to the temp folder:

C:\Users\username\AppData\Local\Temp

where "username" is your logon user. Actually this should not be necessary, because I expect the LaTeX tools to be run under the current user and this should have permission to write to that folder. If LaTeX cannot write there, then LaTeX is perhaps started under a different user. Maybe that is also something to check.

Please try that and report if it helped or not. I'm testing under Win7, but this might not be very exhaustive, because development is still on a WinXP computer.
This forum belongs to www.schmidt-web-berlin.de/winfig

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #5 on: August 03, 2010, 05:41:34 PM »
Thanks for the reply. I granted full control to all users to the Temp folder, but that did not work. I tried changing the latex command to runas /user:Administrador "latex -quiet -job-name OUTFILE INFILE", to make sure that latex was running under the correct user, but it seems that WinFIG did not recognize the command, as nothing happened, not even texclip.log was created. If I run latex from the command line, all works well, though. It seems that the problem arises when WinFIG calls latex.

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #6 on: August 05, 2010, 12:42:43 PM »
Solution: make sure gswin is in the path. For some reason, this does not happen naturally in my Windows 7. Just change the path environment variable to include the path to gswin.

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #7 on: August 05, 2010, 12:52:26 PM »
Sorry, that is not the solution. This only solved a problem I did not know I had. Changing the path allows WinFIG to render the latex formula, but WinFIG still cannot call latex. Essentially, what is happening in my system now is this: I set the characters to special, and then run latex on texclip.tex outside of WinFIG. Then the formulas are shown correctly.

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #8 on: August 06, 2010, 03:34:21 PM »
The trouble with running latex oustide of winfig is if the figure has multiple special texts. In this case, if I close the figure and open it again, all special texts are shown the same, equal to the last dvi that was generated outside of winfig.

Andreas

  • Administrator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: Special + Windows 7
« Reply #9 on: August 13, 2010, 07:46:16 PM »
Thanks for the reply. I granted full control to all users to the Temp folder, but that did not work. I tried changing the latex command to runas /user:Administrador "latex -quiet -job-name OUTFILE INFILE", to make sure that latex was running under the correct user, but it seems that WinFIG did not recognize the command, as nothing happened, not even texclip.log was created.

You could try and call a batch file that contains the command. The batch file can accept parameters via the %-syntax, i.e. %1 for the first parameter and %2 for the second. The file could be named dotex.bat and would contain:

latex -quiet -job-name %1 %2

You would configure WinFIG to execute
dotex.bat OUTFILE INFILE
This forum belongs to www.schmidt-web-berlin.de/winfig

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #10 on: August 16, 2010, 01:37:45 PM »
Thanks for the help. Your suggestion did not quite work. What I observe is that, on the command line, if I first change the directory to my temp and then run latex, all works well. However, if I try to run latex from the miktex directory, giving the path to the texclip file, I get the same error that the aux file cannot be written. But the following batch file worked:

cd "C:\Users\YOURUSERNAME\AppData\Local\Temp"

latex -quiet texclip.tex

I saved it to miktex\bin. I hope that removing INFILE and OUTFILE should not cause much trouble. What are the values of these parameters, by the way?

Thanks!

Andreas

  • Administrator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: Special + Windows 7
« Reply #11 on: August 21, 2010, 10:13:13 PM »
I upgraded MiKTeX to version 2.8 on my laptop and now I have a similar problem there on WinXP. So it's not the windows version, it's the new MikTeX that causes the  problem. Although on my workstation - also with WinXP and MikTeX 2.8 - there is no problem.

WinFIG calls latex like this:

latex -quiet -job-name OUTFILE INFILE

The option -job-name acts as the output name. WinFIG provides full paths using the user's temp directory, so the complete command looks like this:

latex -job-name "c:\documents and settings\aschmidt\local settings\Temp\texclip" "c:\documents and settings\aschmidt
\local settingsTemp\texclip.tex"


Note that latex adds the dvi suffix. Therefore I omit that. This used to work fine with previous MiKTeX versions, but now it fails wit the following error:

! I can't write on file `"c:/documents and settings\aschmidt\local settings/Temp/texclip.aux"'.

That is quite weird, because the path is ok and writable and so I think it's a bug in MikTex. I also tried with a shorter path like that:
latex -job-name "c:\temp\texclip" "c:\temp\texclip.tex"

same result. It only works without a path for the -job-name parameter:

latex -job-name "texclip" "c:\temp\texclip.tex"

But I want to explicitly control where the output goes. I found an alternative that works:

latex -output-directory "c:\documents and settings\aschmidt\local settings\Temp" -job-name "texclip" "c:\documents and settings\aschmidt\local settings\Temp\texclip.tex"

I will provide a new release quickly.
« Last Edit: August 22, 2010, 06:39:56 PM by Andreas »
This forum belongs to www.schmidt-web-berlin.de/winfig

rrlopes

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Special + Windows 7
« Reply #12 on: August 23, 2010, 11:34:21 AM »
Thanks!

Andreas

  • Administrator
  • Full Member
  • *****
  • Posts: 140
    • View Profile
Re: Special + Windows 7
« Reply #13 on: September 04, 2010, 10:21:25 PM »
I just uploaded version 4.6.2, which - I think - solves the problem by using the modified command syntax.
This forum belongs to www.schmidt-web-berlin.de/winfig

simplex

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Special + Windows 7
« Reply #14 on: September 10, 2010, 08:52:38 PM »
This  new version makes things much more convenient on windows 7 / miktex 2.8 (no more UAC windows asking for privileges)
Thanks!